ARM(STM32)

C++を使ったSTM32のプログラミング・デバッグ環境を整える - STM32

最終更新日:2016-11-07 (月) 16:26:57

Linuxユーザのあなたはこちらへ→Linux上でSTM32のプログラミング・デバッグ環境を整える - STM32

動かない場合はすぐに不具合報告をおねがいします!
コメント欄 もしくは Twitter(@tokoro10g)まで

重要なお知らせ

  • 20140119版より前のバージョンでは,STBeeMiniTemplate,STM32F1Templateの2つのサンプルプロジェクトが正常に動作しないバグがあります.

対処方法:

  • STBeeMiniTemplateプロジェクトの場合
    • Libraries/CMSIS/Device/ST/STM32F10x/system_stm32f10x.cをプロジェクトのディレクトリにコピー
    • 128行目を変更
      -#define VECT_TAB_OFFSET  0x0
      +#define VECT_TAB_OFFSET  0x3000
  • STM32F1Templateプロジェクトの場合
    • Libraries/CMSIS/Device/ST/STM32F10x/system_stm32f10x.cをプロジェクトのディレクトリにコピー

ご迷惑をおかけいたしました.

※注意!※

  • 現在64bit版のみの配布です.実行にはJREの64bit版が必要です.
  • 既存の開発環境(miqn.net環境等)のプロジェクトとは互換性がありません
  • コードアシストのショートカットをCtrl+;に設定しています

概要

STM32の開発には,一般的に市販の高価な統合開発環境を使用するか,EclipseとARM向けツールチェイン(Code Sourcery,YAGARTOなど)を組み合わせて開発環境を各自で構築することが前提となっており,マイコンプログラミングの入門者に対する参入障壁となっていた.

マイコン徹底入門」のサイトにはSTM32向けの開発環境が整備されており,日本語によるサポートも非常に充実しているが,C++を使用する環境の構築例や,オンチップデバッグについてはあまり詳しく記載されていない.

一般的な日本人にとって,英語などの外国語で書かれた解説記事やオンライン掲示板の内容を正確に読み解くことは非常に労力のかかる作業であり,そのことからSTM32への入門を諦めてしまう例も散見される.

本記事はSTM32シリーズ全般に対して利用できるC/C++の開発環境と,そのサンプル(テンプレート)プロジェクトを用意し,日本語による解説記事を提供することによって,これらの障壁を取り除こうと試みたものである.

(論文のAbstract風に)

ブツ

(´⊙ɛ ⊙`)つ [ ブツ ]
最終更新:2014/01/19 19:20

使い方 - ビルド編

  1. 解凍します
  2. ねむいさんのぶろぐのおきばからOpenOCDバイナリをダウンロードして,ocdフォルダに解凍します
    フォルダはだいたいこんな感じになります
    d66732.png
  3. Eclipseを起動します.デフォルトでワークスペースが開かれていない場合は,File-> Switch Workspace->Other...から,自分が解凍したフォルダの中のworkspaceフォルダを選択して開きます.
    eclipse_workspace.png
  4. とりあえずどれかビルドしてみましょう
    eclipse_build.png
    こんな感じでビルドに成功したら勝ちです.あとは好きに書いて好きにビルドしてください.
    f45b53.png
    (13.06.26 11:00追記)
    コンソール上でなくエディタ上でエラーや警告が出ている場合は,インデックスを再作成することで解決します.
    eclipse_index_error.png
    プロジェクトを右クリックしてIndex->Rebuildを実行すると,エラーが消えます.
    eclipse_index_rebuild.png

使い方 - デバッグ編

  1. ST-LinkやDiscovery基板をUSB接続した状態でOpenOCDを起動します
    F1,F2,F3,F4シリーズに対応しています.それぞれ当てはまるものを起動してください.
    eclipse_openocd.png
    成功すると,画面下のコンソールにインフォメーションが表示されます.
    37c3ca.png
    ここで怒られたあなたは,接続を確認するか,ねむいさんのぶろぐからOpenOCDをきちんとダウンロードしてきたかどうか確認してください.
    ST-Linkを自作基板とつないで使う場合は,自作基板側の電源もONにしておいてください.
    これらをチェックしてもうまくいかない場合は,ドライバが悪さをしていることがありますので,次の手順に従ってください.
    1. デバッグやOpenOCDを終了しておきます(赤い■ボタン)
    2. 同梱のzadig.exeを起動します
    3. Options->List all Devicesをクリックします
      zadig.png
    4. STM32 STLinkが選択されていることを必ず確認してからUpgrade Driverをクリックします.
      zadig_upgrade.png
    5. ドライバがインストールされ,準備が整いました.手順1に戻って再度試してみてください.
  2. 次に,画面上の虫マークからテンプレートに対応するデバッグ構成を選択して起動します
    eclipse_debug.png
    次のようなエラーメッセージで怒られた場合は,プロジェクトエクスプローラ上でプロジェクトを選択してから再度デバッグを実行してみてください.
    829ed5.png
    デバッグの設定はプロジェクトを複製しても複製されないので,テンプレートプロジェクトをコピーする場合は,デバッグの構成ウィンドウで構成を複製して使ってください.
    eclipse_debug_conf.png
  3. デバッグが始まります
    eclipse_debug_window.png
    デフォルトではmain関数にブレークポイントを設定してからReset_Handlerを呼んでいます.
    プログラムをスタートするには,画面上部のリジュームボタンをクリックします.
    eclipse_debug_resume.png
  4. レジスタの中身を見たり変えたりしたいときは,画面下部からEmbSys Registersタブを開いてください.
    eclipse_debug_register.png
  5. ブレークポイントを設定したり,ステップインなどの機能を使って思う存分遊んじゃってください.

内容物

  • Eclipse
    • Eclipse IDE for C/C++ Developers (Juno) 1.5.2.20130211-1820
    • C/C++ GDB Hardware Debugging 7.0.0.201302132326
    • Embedded Systems Register View (SFR) 0.2.3
  • YAGARTO
    • yagarto 20111119
    • yagarto-tools 20100703
  • Libraries
    • STM32F0xx Standard Peripherals Library
    • STM32F10x Standard Peripherals Library
    • STM32F2xx Standard Peripherals Library
    • STM32F30x Standard Peripherals Library
    • STM32F4xx Standard Peripherals Library
    • STM32 USB OTG Driver
    • STM32 USB Host Library
    • STM32 USB Device Library
    • STM32 CPAL Driveer
    • Baselibc( https://github.com/PetteriAimonen/Baselibc )
    • STM32 EEPROM Emulation Library
    • DFUW( http://strawberry-linux.com/stbee/dfuw ) (for STBee series)
  • Example Projects
    • STM32F1Template
    • STM32F2Template
    • STM32F3Template
    • STM32F4Template
    • STBeeMiniTemplate
  • External Tools
    • Zadig(OpenOCD用にドライバを更新するのに必要)

著作権に関して

Eclipse,YAGARTO,Zadig,DFUW,各種ライブラリは二次配布物であり,その著作権はそれぞれの作者に帰属します. 一応下調べはしてありますが,ライセンス等の関係で問題があるようでしたらお知らせください.

サンプルプロジェクトのコードは著作権フリーとして扱います. ご自由に改変・再配布いただいて構いません.

コメント欄

  • YAGARTOがもう開発しないらしくてサポートもしないらしいので,別のツールチェインに変えたほうが良いかもしれないです. -- tanitanin? 2013-08-29 (木) 12:32:56
  • @tanitanin Code Sourceryも実質有償化の流れですし,自分でツールチェインをビルドできればいいんですがねぇ・・・ -- Tokoro? 2013-08-30 (金) 01:55:29
  • example prjをコピー、リネームするとbuildエラーになります。 -- s-shige? 2016-10-25 (火) 17:12:25
  • example prjをコピー、リネームするとbuildエラーになります。 -- s-shige? 2016-10-25 (火) 18:44:00
  • mainにとぶまえにHadFaultが発生します。 -- s-shige? 2016-11-07 (月) 16:24:48
  • RCC->CIR = 0x00000000;にアクセスすると、暴走し、結果HardFaultになります -- s-shige? 2016-11-07 (月) 16:26:57


添付ファイル: fileeclipse_index_error.png 485件 [詳細] fileeclipse_index_rebuild.png 498件 [詳細] filezadig_upgrade.png 404件 [詳細] filezadig.png 458件 [詳細] fileeclipse_workspace.png 554件 [詳細] fileeclipse_openocd.png 333件 [詳細] fileeclipse_debug_window.png 418件 [詳細] fileeclipse_debug_resume.png 394件 [詳細] fileeclipse_debug_register.png 492件 [詳細] fileeclipse_debug_conf.png 330件 [詳細] fileeclipse_debug.png 521件 [詳細] fileeclipse_build.png 518件 [詳細]

トップ   編集 凍結 差分 バックアップ 添付 複製 名前変更 リロード   新規 一覧 単語検索 最終更新   ヘルプ   最終更新のRSS
Last-modified: 2016-11-07 (月) 16:26:57 (377d)